Trillian < 3.1.6.0 Multiple Vulnerabilities

This script is Copyright (C) 2007-2017 Tenable Network Security, Inc.


Synopsis :

The remote host contains an instant messaging application that is
affected by a buffer overflow vulnerability.

Description :

The version of Trillian installed on the remote host reportedly is
affected by a heap-based buffer overflow issue involving improper
handling of UTF-8 sequences when word-wrapping UTF-8 text. A remote
attacker may be able to leverage these issues to execute arbitrary
code as the current user.

See also :

http://www.nessus.org/u?bcd19445
http://www.securityfocus.com/archive/1/471673/30/0/threaded
http://web.archive.org/web/20160320091220/http://blog.trillian.im/?p=150

Solution :

Upgrade to Trillian 3.1.6.0 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 25547 ()

Bugtraq ID: 24523

CVE ID: CVE-2007-3305

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now