WinProxy < 6.1r1c HTTP CONNECT Request Remote Overflow

This script is Copyright (C) 2007-2016 Tenable Network Security, Inc.


Synopsis :

The remote HTTP proxy is affected by a buffer overflow vulnerability.

Description :

The remote host is running WinProxy, a proxy server for Windows.

The version of WinProxy installed on the remote host reportedly
contains a design issue that may result in a buffer overflow
vulnerability. Using a specially crafted HTTP CONNECT request, a
remote attacker may be able to leverage this issue to execute
arbitrary code on the affected host subject to the privileges under
which the service runs.

See also :

http://www.nessus.org/u?b6aefeed
http://seclists.org/fulldisclosure/2007/Feb/106

Solution :

Upgrade to WinProxy version 6.1r1c or later as it is rumored to
address the issue.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 24277 ()

Bugtraq ID: 22393

CVE ID: CVE-2007-0796

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now