OpenSSH < 4.4 Multiple Vulnerabilities

This script is Copyright (C) 2006-2016 Tenable Network Security, Inc.

Synopsis :

The remote SSH server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of OpenSSH installed on the
remote host is affected by multiple vulnerabilities :

- A race condition exists that may allow an
unauthenticated, remote attacker to crash the service
or, on portable OpenSSH, possibly execute code on the
affected host. Note that successful exploitation
requires that GSSAPI authentication be enabled.

- A flaw exists that may allow an attacker to determine
the validity of usernames on some platforms. Note that
this issue requires that GSSAPI authentication be

- When SSH version 1 is used, an issue can be triggered
via an SSH packet that contains duplicate blocks that
could result in a loss of availability for the service.

- On Fedora Core 6 (and possibly other systems), an
unspecified vulnerability in the
linux_audit_record_event() function allows remote
attackers to inject incorrect information into
audit logs.

See also :

Solution :

Upgrade to OpenSSH 4.4 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now