Winamp < 5.22 Malformed Midi File Handling Buffer Overflow

This script is Copyright (C) 2006-2011 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a multimedia application that is
prone to a buffer overflow attack.

Description :

The remote host is using Winamp, a popular media player for Windows.

The version of Winamp installed on the remote Windows host reportedly
contains a buffer overflow in the 'in_midi.dll' library that can be
exploited using a specially crafted MIDI file to either crash the
affected application or possibly even execute arbitrary code remotely,
subject to the privileges of the user running the application.

See also :

http://www.fortinet.com/FortiGuardCenter/advisory/FG-2006-16.html
http://www.winamp.com/player/version-history

Solution :

Upgrade to Winamp version 5.22 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.8
(CVSS2#E:F/RL:U/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 21733 ()

Bugtraq ID: 18507

CVE ID: CVE-2006-3228

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now