Mandrake Linux Security Advisory : php (MDKSA-2006:091)

This script is Copyright (C) 2006-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mandrake Linux host is missing one or more security
updates.

Description :

An integer overflow in the wordwrap() function could allow attackers
to execute arbitrary code via certain long arguments that cause a
small buffer to be allocated, triggering a heap-based buffer overflow
(CVE-2006-1990).

The substr_compare() function in PHP 5.x and 4.4.2 could allow
attackers to cause a Denial of Service (memory access violation) via
an out-of-bounds offset argument (CVE-2006-1991).

The second vulnerability only affects Mandriva Linux 2006; earlier
versions shipped with older versions of PHP that do not contain the
substr_compare() function.

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 21602 (mandrake_MDKSA-2006-091.nasl)

Bugtraq ID:

CVE ID: CVE-2006-1990
CVE-2006-1991

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now