FreeBSD : kaffeine -- buffer overflow vulnerability (4bfcd857-c628-11da-b2fb-000e0c2e438a)

This script is Copyright (C) 2006-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

The KDE team reports :

Kaffeine can produce a buffer overflow in http_peek() while creating
HTTP request headers for fetching remote playlists, which under
certain circumstances could be used to crash the application and/or
execute arbitrary code.

See also :

http://www.kde.org/info/security/advisory-20060404-1.txt
http://www.nessus.org/u?af370951

Solution :

Update the affected package.

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 3.8
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 21426 (freebsd_pkg_4bfcd857c62811dab2fb000e0c2e438a.nasl)

Bugtraq ID: 17372

CVE ID: CVE-2006-0051

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now