FreeBSD : postgresql81-server -- SET ROLE privilege escalation (0b2b4b4d-a07c-11da-be0a-000c6ec775d9)

This script is Copyright (C) 2006-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

The PostgreSQL team reports :

Due to inadequate validity checking, a user could exploit the special
case that SET ROLE normally uses to restore the previous role setting
after an error. This allowed ordinary users to acquire superuser
status, for example.

See also :

http://www.postgresql.org/docs/8.1/static/release.html#RELEASE-8-1-3
http://www.nessus.org/u?4a9589bf

Solution :

Update the affected package.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 21384 (freebsd_pkg_0b2b4b4da07c11dabe0a000c6ec775d9.nasl)

Bugtraq ID:

CVE ID: CVE-2006-0553

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now