Winamp < 5.2 Multiple Vulnerabilities

This script is Copyright (C) 2006-2013 Tenable Network Security, Inc.


Synopsis :

A multimedia application that is vulnerable to denial of service
attacks is installed on the remote Windows host.

Description :

The remote host is using Winamp, a popular media player for Windows.

The version of Winamp installed on the remote Windows host reportedly
crashes if the user tries to open an M3U file with a long filename.

In addition, it reportedly contains a buffer overflow flaw that can be
exploited using a specially crafted M3U file to either crash the
application or possibly even execute arbitrary code remotely.

See also :

http://www.securityfocus.com/archive/1/424903/30/0/threaded
http://www.securityfocus.com/archive/1/425888/30/0/threaded
http://www.winamp.com/player/version-history

Solution :

Upgrade to Winamp version 5.2 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 20973 ()

Bugtraq ID: 16623
16785

CVE ID: CVE-2006-0708
CVE-2006-0720

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now