FreeBSD : MySQL authentication bypass / buffer overflow (e5e2883d-ceb9-11d8-8898-000d6111a684)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

By submitting a carefully crafted authentication packet, it is
possible for an attacker to bypass password authentication in MySQL
4.1. Using a similar method, a stack buffer used in the authentication
mechanism can be overflowed.

See also :

http://www.nextgenss.com/advisories/mysql-authbypass.txt
http://dev.mysql.com/doc/mysql/en/News-4.1.3.html
http://archives.neohapsis.com/archives/vulnwatch/2004-q3/0003.html
http://www.nessus.org/u?4f9fd41a

Solution :

Update the affected packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
Public Exploit Available : true

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 19149 (freebsd_pkg_e5e2883dceb911d88898000d6111a684.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0627
CVE-2004-0628

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now