FreeBSD : xpdf -- buffer overflow vulnerability (e3e266e9-5473-11d9-a9e7-0001020eed82)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

An iDEFENSE Security Advisory reports :

Remote exploitation of a buffer overflow vulnerability in the xpdf PDF
viewer, as included in multiple Linux distributions, could allow
attackers to execute arbitrary code as the user viewing a PDF file.
The offending code can be found in the Gfx::doImage() function in the
source file xpdf/Gfx.cc.

See also :

http://www.nessus.org/u?89673295
http://www.nessus.org/u?949abad6

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 19147 (freebsd_pkg_e3e266e9547311d9a9e70001020eed82.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1125

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now