FreeBSD : phpmyadmin -- file disclosure vulnerability (9f0a405e-4edd-11d9-a9e7-0001020eed82)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

A phpMyAdmin security announcement reports :

File disclosure: on systems where the UploadDir mecanism is active,
read_dump.php can be called with a crafted form; using the fact that
the sql_localfile variable is not sanitized can lead to a file
disclosure.

Enabling PHP safe mode on the server can be used as a workaround for
this vulnerability.

See also :

http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2004-4
http://www.nessus.org/u?8c2304be
http://www.nessus.org/u?412d0fe9

Solution :

Update the affected package.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 19051 (freebsd_pkg_9f0a405e4edd11d9a9e70001020eed82.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1148

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now