FreeBSD : curl -- authentication buffer overflow vulnerability (96df5fd0-8900-11d9-aa18-0001020eed82)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

Two iDEFENSE Security Advisories reports :

An exploitable stack-based buffer overflow condition exists when using
NT Lan Manager (NTLM) authentication. The problem specifically exists
within Curl_input_ntlm() defined in lib/http_ntlm.c.

Successful exploitation allows remote attackers to execute arbitrary
code under the privileges of the target user. Exploitation requires
that an attacker either coerce or force a target to connect to a
malicious server using NTLM authentication.

An exploitable stack-based buffer overflow condition exists when using
Kerberos authentication. The problem specifically exists within the
functions Curl_krb_kauth() and krb4_auth() defined in lib/krb4.c.

Successful exploitation allows remote attackers to execute arbitrary
code under the privileges of the target user. Exploitation requires
that an attacker either coerce or force a target to connect to a
malicious server using Kerberos authentication.

See also :

http://marc.info/?l=bugtraq&m=110902850731457
http://marc.info/?l=bugtraq&m=110902601221592
http://www.nessus.org/u?e03599e6

Solution :

Update the affected package.

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 3.8
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 19038 (freebsd_pkg_96df5fd0890011d9aa180001020eed82.nasl)

Bugtraq ID: 12615
12616

CVE ID: CVE-2005-0490

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now