FreeBSD : postgresql -- multiple buffer overflows in PL/PgSQL parser (6b4b0b3f-8127-11d9-a9e7-0001020eed82)

This script is Copyright (C) 2005-2015 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

The PL/PgSQL parser in postgresql is vulnerable to several buffer
overflows. These could be exploited by a remote attacker to execute
arbitrary code with the permissions of the postgresql server by
running a specially crafted query.

See also :

http://archives.postgresql.org/pgsql-committers/2005-02/msg00049.php
http://www.nessus.org/u?39a36a2b

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 18973 (freebsd_pkg_6b4b0b3f812711d9a9e70001020eed82.nasl)

Bugtraq ID:

CVE ID: CVE-2005-0247

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now