FreeBSD : xshisen -- local buffer overflows (56971fa6-641c-11d9-a097-000854d03344)

This script is Copyright (C) 2005-2016 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

Steve Kemp has found buffer overflows in the handling of the command
line flag -KCONV and the XSHISENLIB environment variable. Ulf
Harnhammer has detected an unbounded copy from the GECOS field to a
char array. All overflows can be exploited to gain group games
privileges.

See also :

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=213957
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=289784
http://www.nessus.org/u?dc82bcee

Solution :

Update the affected package.

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 18939 (freebsd_pkg_56971fa6641c11d9a097000854d03344.nasl)

Bugtraq ID:

CVE ID: CVE-2003-1053
CVE-2005-0117

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now