FreeBSD : gdk-pixbuf -- image decoding vulnerabilities (3d1e9267-073f-11d9-b45d-000c41e2cdad)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

Chris Evans discovered several flaws in the gdk-pixbuf XPM image
decoder :

- Heap-based overflow in pixbuf_create_from_xpm

- Stack-based overflow in xpm_extract_color

- Integer overflows in io-ico.c

Some of these flaws are believed to be exploitable.

See also :

http://scary.beasts.org/security/CESA-2004-005.txt
http://www.nessus.org/u?05c72700

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 18908 (freebsd_pkg_3d1e9267073f11d9b45d000c41e2cdad.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0782
CVE-2004-0783
CVE-2004-0788

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now