PostgreSQL < 8.0.3 Multiple Vulnerabilities

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of PostgreSQL installed on the
remote host may suffer from the following vulnerabilities :

- Character Conversion Vulnerability
Unprivileged users can call functions supporting client-
server character set conversion from SQL commands even
though those functions do not validate their arguments.

- tsearch2 Vulnerability
If installed, the 'contrib/tsearch2' module permits
to at a minimum crash the backend because it misdeclares
several functions as returning type 'internal' when in
fact they do not have any 'internal' argument.

See also :

Solution :

Implement the changes described in the PostgreSQL advisory or upgrade
to 8.0.3.

Risk factor :

Medium / CVSS Base Score : 6.5
CVSS Temporal Score : 4.8
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 18202 ()

Bugtraq ID: 13475

CVE ID: CVE-2005-1409

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now