OpenSSL < 0.9.8f Multiple Vulnerabilities

This script is Copyright (C) 2012-2017 Tenable Network Security, Inc.

Synopsis :

The remote server is affected by multiple vulnerabilities.

Description :

According to its banner, the remote server is running a version of
OpenSSL that is earlier than 0.9.8f. As such, it is affected by the
following vulnerabilities :

- A local attacker could perform a side-channel attack
against the Montgomery multiplication code and retrieve
RSA private keys. Note that this has not been exploited
outside a laboratory environment. (CVE-2007-3108)

- A remote attacker could execute arbitrary code by
exploiting an off-by-one error in the DTLS
implementation. (CVE-2007-4995)

See also :

Solution :

Upgrade to OpenSSL 0.9.8f or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 6.9
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 17760 ()

Bugtraq ID: 25163

CVE ID: CVE-2007-3108

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now