Mandrake Linux Security Advisory : squid (MDKSA-2005:034)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mandrake Linux host is missing a security update.

Description :

More vulnerabilities were discovered in the squid server :

The LDAP handling of search filters was inadequate which could be
abused to allow logins using severial variants of a single login name,
possibly bypassing explicit access controls (CVE-2005-0173).

Minor problems in the HTTP header parsing code that could be used for
cache poisoning (CVE-2005-0174 and CVE-2005-0175).

A buffer overflow in the WCCP handling code allowed remote attackers
to cause a Denial of Service and could potentially allow for the
execution of arbitrary code by using a long WCCP packet.

The updated packages have been patched to prevent these problems.

See also :

http://www.squid-cache.org/Advisories/SQUID-2005_3.txt

Solution :

Update the affected squid package.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 16377 (mandrake_MDKSA-2005-034.nasl)

Bugtraq ID:

CVE ID: CVE-2005-0173
CVE-2005-0174
CVE-2005-0175
CVE-2005-0211

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now