Mandrake Linux Security Advisory : cups (MDKSA-2005:018)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mandrake Linux host is missing one or more security
updates.

Description :

A buffer overflow vulnerability was discovered in the xpdf PDF code,
which could allow for arbitrary code execution as the user viewing a
PDF file. The vulnerability exists due to insufficient bounds checking
while processing a PDF file that provides malicious values in the
/Encrypt /Length tag. Cups uses xpdf code and is susceptible to the
same vulnerability.

The updated packages have been patched to prevent these problems.

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 16255 (mandrake_MDKSA-2005-018.nasl)

Bugtraq ID:

CVE ID: CVE-2005-0064

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now