Mandrake Linux Security Advisory : imlib (MDKSA-2005:007)

This script is Copyright (C) 2005-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mandrake Linux host is missing one or more security
updates.

Description :

Pavel Kankovsky discovered several heap overflow flaw in the imlib
image handler. An attacker could create a carefully crafted image file
in such a way that it could cause an application linked with imlib to
execute arbitrary code when the file was opened by a user
(CVE-2004-1025).

As well, Pavel also discovered several integer overflows in imlib.
These could allow an attacker, creating a carefully crafted image
file, to cause an application linked with imlib to execute arbitrary
code or crash (CVE-2004-1026).

The updated packages have been patched to prevent these problems.

Solution :

Update the affected packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 16158 (mandrake_MDKSA-2005-007.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1025
CVE-2004-1026

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now