Mandrake Linux Security Advisory : a2ps (MDKSA-2004:140)

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Mandrake Linux host is missing one or more security
updates.

Description :

The GNU a2ps utility fails to properly sanitize filenames, which can
be abused by a malicious user to execute arbitrary commands with the
privileges of the user running the vulnerable application.

The updated packages have been patched to prevent this problem.

Solution :

Update the affected a2ps, a2ps-devel and / or a2ps-static-devel
packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Family: Mandriva Local Security Checks

Nessus Plugin ID: 15838 (mandrake_MDKSA-2004-140.nasl)

Bugtraq ID: 11025

CVE ID: CVE-2004-1170

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now