MySQL < 4.0.21 Multiple Vulnerabilities

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

You are running a version of MySQL which is older than version 4.0.21.
Such versions are potentially affected by two flaws :

- There is an unauthorized database GRANT privilege
vulnerability, which may allow an attacker to misuse the
GRANT privilege it has been given and to use it against
other databases. (CVE-2004-0957)

- A denial of service vulnerability may be triggered by
the misuse of the FULLTEXT search functionality.

See also :

Solution :

Upgrade to MySQL 4.0.21 or later, as this reportedly fixes the issue.

Risk factor :

Medium / CVSS Base Score : 6.8
CVSS Temporal Score : 5.9
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 15477 ()

Bugtraq ID: 11435

CVE ID: CVE-2004-0957

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now