GLSA-200403-14 : Multiple Security Vulnerabilities in Monit

This script is Copyright (C) 2004-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200403-14
(Multiple Security Vulnerabilities in Monit)

A denial of service may occur due to Monit not sanitizing remotely
supplied HTTP parameters before passing them to memory allocation
functions. This could allow an attacker to cause an unexpected
condition that could lead to the Monit daemon crashing.
An overly long http request method may cause a buffer overflow due to
Monit performing insufficient bounds checking when handling HTTP

Impact :

An attacker may crash the Monit daemon to create a denial of service
condition or cause a buffer overflow that would allow arbitrary code to
be executed with root privileges.

Workaround :

A workaround is not currently known for this issue. All users are
advised to upgrade to the latest version of the affected package.

See also :

Solution :

Monit users should upgrade to version 4.2 or later:
# emerge sync
# emerge -pv '>=app-admin/monit-4.2'
# emerge '>=app-admin/monit-4.2'

Risk factor :

Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 8.3
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14465 (gentoo_GLSA-200403-14.nasl)

Bugtraq ID: 9098

CVE ID: CVE-2003-1083

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now