Mandrake Linux Security Advisory : XFree86 (MDKSA-2004:012)

This script is Copyright (C) 2004-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mandrake Linux host is missing one or more security
updates.

Description :

Two buffer overflow vulnerabilities were found by iDEFENSE in
XFree86's parsing of the font.alias file. The X server, which runs as
root, fails to check the length of user-provided input; as a result a
malicious user could craft a malformed font.alias file causing a
buffer overflow upon parsing, which could eventually lead to the
execution of arbitrary code.

Additional vulnerabilities were found by David Dawes, also in the
reading of font files.

The updated packages have a patch from David Dawes to correct these
vulnerabilities.

Solution :

Update the affected packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 14112 (mandrake_MDKSA-2004-012.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0083
CVE-2004-0084
CVE-2004-0106

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now