Mandrake Linux Security Advisory : fetchmail (MDKSA-2002:063)

This script is Copyright (C) 2004-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mandrake Linux host is missing one or more security
updates.

Description :

Several buffer overflows and a boundary check error were discovered in
all fetchmail versions prior to 6.1.0 by e-matters GmbH. These
problems are vulnerable to crashes and/or arbitrary code execution by
remote attackers if fetchmail is running in multidrop mode. The code
execution would be done with the same privilege as the user running
fetchmail.

See also :

http://security.e-matters.de/advisories/032002.html

Solution :

Update the affected fetchmail, fetchmail-daemon and / or fetchmailconf
packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Mandriva Local Security Checks

Nessus Plugin ID: 13964 (mandrake_MDKSA-2002-063.nasl)

Bugtraq ID:

CVE ID: CVE-2002-1174
CVE-2002-1175

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now