openSUSE Security Update : git (openSUSE-2017-1115)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for git to version 2.13.6 fixes the following issues :

- CVE-2017-14867: Various Perl scripts did not use
safe_pipe_capture() instead of backticks, leaving them
susceptible to end-user input (boo#1061041)

As an additional measure, 'git cvsserver' no longer is invoked by 'git
daemon' by default.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1061041

Solution :

Update the affected git packages.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 103622 ()

Bugtraq ID:

CVE ID: CVE-2017-14867

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now