macOS : macOS Server < 5.4 Multiple Vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote host is missing a security update for macOS Server.

Description :

The version of macOS Server (formerly known as Mac OS X Server)
installed on the remote host is prior to 5.4. It is, therefore,
affected by the multiple Buffer Overflow DoS vulnerabilities in
FreeRADIUS

See also :

https://support.apple.com/en-us/HT208102

Solution :

Upgrade to macOS Server version 5.4 or later. Note that macOS Server
version 5.4 is available only for macOS 10.12.4 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.2
(CVSS2#E:U/RL:U/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 103531 ()

Bugtraq ID: 99893
99901

CVE ID: CVE-2017-10978
CVE-2017-10979

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now