GLSA-201709-20 : Postfix: Privilege escalation

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201709-20
(Postfix: Privilege escalation)

By default, Berkeley DB reads a DB_CONFIG configuration file from the
current working directory. This is an undocumented behavior.

Impact :

A local attacker, by using a specially crafted DG_CONFIG file, could
possibly escalate privileges to the root group.

Workaround :

There is no known workaround at this time.

See also :

https://www.postfix.org/announcements/postfix-3.2.2.html
https://security.gentoo.org/glsa/201709-20

Solution :

All Postfix users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=mail-mta/postfix-3.1.6'

Risk factor :

High

Family: Gentoo Local Security Checks

Nessus Plugin ID: 103448 ()

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now