VMware Workstation 12.x < 12.5.7 Multiple Vulnerabilities (VMSA-2017-0015)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

A virtualization application installed on the remote Windows host is
affected by multiple vulnerabilities.

Description :

The version of VMware Workstation installed on the remote Windows host
is 12.x prior to 12.5.7. It is, therefore, affected by the following
vulnerabilities:

- A remote code execution vulnerability exists in VMware
workstation within the SVGA device. An attacker with
user access can exploit this to execute arbitrary
code. (CVE-2017-4924)

- A denial of service vulnerability exists in VMware
workstation due to a NULL pointer deference when
handling guest RPC requests. An attacker with guest
access can exploit this to crash their VMs.
NOTE: This vulnerability only affects VMware
Workstation 12.5.2 and below. (CVE-2017-4925)

See also :

https://www.vmware.com/us/security/advisories/VMSA-2017-0015.html

Solution :

Upgrade to VMware Workstation version 12.5.7 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:L/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 5.0
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 103380 ()

Bugtraq ID: 100842
100843

CVE ID: CVE-2017-4924
CVE-2017-4925

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now