GLSA-201709-04 : mod_gnutls: Certificate validation error

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201709-04
(mod_gnutls: Certificate validation error)

It was discovered that the authentication hook in mod_gnutls does not
validate client’s certificates even when option
“GnuTLSClientVerify” is set to “require”.

Impact :

A remote attacker could present a crafted certificate and spoof clients
data.

Workaround :

There is no known workaround at this time.

See also :

https://security.gentoo.org/glsa/201709-04

Solution :

All mod_gnutls users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apache/mod_gnutls-0.7.3'

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 103272 ()

Bugtraq ID:

CVE ID: CVE-2015-2091

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now