GLSA-201709-03 : WebKitGTK+: Multiple vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201709-03
(WebKitGTK+: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in WebkitGTK+. Please
review the references below for details.

Impact :

A remote attacker could execute arbitrary code via crafted web content.

Workaround :

There is no known workaround at this time.

See also :

https://webkitgtk.org/security/WSA-2017-0005.html
https://security.gentoo.org/glsa/201709-03

Solution :

All WebkitGTK+ users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-libs/webkit-gtk-2.16.5'
Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 103271 ()

Bugtraq ID:

CVE ID: CVE-2017-2424
CVE-2017-2538

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now