Adobe Flash Player for Mac <= 26.0.0.151 Multiple Vulnerabilities (APSB17-23)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote macOS or Mac OS X host has a browser plugin installed that
is affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote macOS or Mac
OS X host is equal or prior to version 26.0.0.151. It is, therefore,
affected by multiple vulnerabilities :

- An unspecified memory corruption flaw exists that is
caused by input not being properly validated. An
unauthenticated, remote attacker can exploit this, by
convincing a user to visit a website containing specially
crafted Flash content, to to corrupt memory and
potentially execute arbitrary code.
(CVE-2017-11281, CVE-2017-11282)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb17-28.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 27.0.0.130 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 103125 ()

Bugtraq ID: 100710
100716

CVE ID: CVE-2017-11281
CVE-2017-11282

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now