Apache Struts 2.1.x >= 2.1.2 / 2.2.x / 2.3.x < 2.3.34 / 2.5.x < 2.5.13 Multiple Vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

A web application running on the remote host uses a Java framework
that is affected by multiple vulnerabilities.

Description :

The version of Apache Struts running on the remote host is 2.1.x
subsequent or equal to 2.1.2, 2.2.x, 2.3.x prior to 2.3.34, or 2.5.x
prior to 2.5.13. It is, therefore, affected by multiple
vulnerabilities:

- A remote code execution vulnerability in the REST plugin. The
Struts REST plugin uses an XStreamHandler with an instance of
XStream for deserialization and does not perform any type
filtering when deserializing XML payloads. This can allow an
unauthenticated, remote attacker to execute arbitrary code in the
context of the Struts REST plugin by sending a specially crafted
XML payload. (CVE-2017-9805)

- A denial of service vulnerability in the XStream XML deserializer
in the XStreamHandler used by the REST plugin. (CVE-2017-9793)

- A denial of service vulnerability when using URLValidator.
(CVE-2017-9804)

- A flaw exists related to 'freemarker' tags, expression literals,
'views/freemarker/FreemarkerManager.java', and forced
expressions that allows arbitrary code execution.
(CVE-2017-12611)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

https://cwiki.apache.org/confluence/display/WW/Version+Notes+2.3.34
https://cwiki.apache.org/confluence/display/WW/Version+Notes+2.5.13
https://cwiki.apache.org/confluence/display/WW/S2-050
https://cwiki.apache.org/confluence/display/WW/S2-051
https://cwiki.apache.org/confluence/display/WW/S2-052
https://cwiki.apache.org/confluence/display/WW/S2-053
https://lgtm.com/blog/apache_struts_CVE-2017-9805_announcement
https://lgtm.com/blog/apache_struts_CVE-2017-9805
http://www.nessus.org/u?45c4be36
http://seclists.org/oss-sec/2017/q3/406

Solution :

Upgrade to Apache Struts version 2.3.34 or 2.5.13 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 102960 ()

Bugtraq ID: 100609
100611
100612
100829

CVE ID: CVE-2017-9793
CVE-2017-9804
CVE-2017-9805
CVE-2017-12611

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now