Asterisk 11.x < 11.25.2 / 11.6 < 11.6-cert17 / 13.x < 13.17.1 / 14.x < 14.6.1 / 13.13 < 13.13-cert5 Multiple Vulnerabilities (AST-2017-005 - AST-2017-007)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

A telephony application running on the remote host is affected by
multiple vulnerabilities.

Description :

According to its SIP banner, the version of Asterisk running on the
remote host is 11.x prior to 11.25.2, 13.x prior to 13.17.1, 14.x prior to 14.6.1,
11.6 prior to 11.6-cert17, or 13.13 prior to 13.13-cert5. It is therefore, affected by multiple
vulnerabilities as described in AST-2017-005, AST-2017-006, and AST-2017-007.

Note for AST-2017-005, only 11.4.0 is affected in the 11.x branch.

Also note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://downloads.asterisk.org/pub/security/AST-2017-005.html
http://downloads.asterisk.org/pub/security/AST-2017-006.html
http://downloads.asterisk.org/pub/security/AST-2017-007.html

Solution :

Upgrade to Asterisk version 11.25.2 / 13.17.1 / 14.6.1 / 11.6-cert17 / 13.13-cert5 or later.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 102958 ()

Bugtraq ID:

CVE ID: CVE-2017-14098
CVE-2017-14099
CVE-2017-14100

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now