openSUSE Security Update : libzypp (openSUSE-2017-989)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

The Software Update Stack was updated to receive fixes and
enhancements.

libzypp :

- CVE-2017-7435, CVE-2017-7436, CVE-2017-9269: Fix GPG
check workflows, mainly for unsigned repositories and
packages. (bsc#1045735, bsc#1038984)

- Fix gpg-pubkey release (creation time) computation.
(bsc#1036659)

- Update lsof blacklist. (bsc#1046417)

- Re-probe on refresh if the repository type changes.
(bsc#1048315)

- Propagate proper error code to DownloadProgressReport.
(bsc#1047785)

- Allow to trigger an appdata refresh unconditionally.
(bsc#1009745)

- Support custom repo variables defined in
/etc/zypp/vars.d.

yast2-pkg-bindings :

- Do not crash when the repository URL is not defined.
(bsc#1043218)

This update was imported from the SUSE:SLE-12-SP3:Update update
project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1009745
https://bugzilla.opensuse.org/show_bug.cgi?id=1036659
https://bugzilla.opensuse.org/show_bug.cgi?id=1038984
https://bugzilla.opensuse.org/show_bug.cgi?id=1043218
https://bugzilla.opensuse.org/show_bug.cgi?id=1045735
https://bugzilla.opensuse.org/show_bug.cgi?id=1046417
https://bugzilla.opensuse.org/show_bug.cgi?id=1047785
https://bugzilla.opensuse.org/show_bug.cgi?id=1048315

Solution :

Update the affected libzypp packages.

Risk factor :

High

Family: SuSE Local Security Checks

Nessus Plugin ID: 102944 ()

Bugtraq ID:

CVE ID: CVE-2017-7435
CVE-2017-7436
CVE-2017-9269

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now