Wireshark 2.4.x < 2.4.1 Multiple DoS

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

An application installed on the remote Windows host is affected by
multiple denial of service vulnerabilities.

Description :

The version of Wireshark installed on the remote Windows host is 2.4.x
prior to 2.4.1. It is, therefore, affected by multiple denial of
service vulnerabilities in the Modbus, IrCOMM, Profinet I/O, and MSDP
dissectors. An unauthenticated, remote attacker can exploit this by
injecting a malformed packet onto the wire or by convincing someone to
read a malformed packet trace file.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

https://www.wireshark.org/docs/relnotes/wireshark-2.4.1.html
https://www.wireshark.org/security/wnpa-sec-2017-38.html
https://www.wireshark.org/security/wnpa-sec-2017-39.html
https://www.wireshark.org/security/wnpa-sec-2017-40.html
https://www.wireshark.org/security/wnpa-sec-2017-41.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=13847
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=13925
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=13929
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=13933

Solution :

Upgrade to Wireshark version 2.4.1 or later.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 6.4
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 102921 ()

Bugtraq ID:

CVE ID: CVE-2017-13764
CVE-2017-13765
CVE-2017-13766
CVE-2017-13767

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now