SUSE SLED12 Security Update : libraw (SUSE-SU-2017:2300-1)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote SUSE host is missing one or more security updates.

Description :

This update for libraw fixes the following issues :

- CVE-2015-3885: A specially crafted raw image file could
have caused a Denial of Service through an integer
overflow. (bsc#930683)

- CVE-2015-8367: The function phase_one_correct() did not
handle memory object initialization correctly, which may
have caused some other problems. (bsc#957517)

- CVE-2017-6886: memory corruption in parse_tiff_ifd()
func (internal/dcraw_common.cpp) could lead to Denial of
service (bsc#1039380)

- CVE-2017-6889: integer overflow error within the
'foveon_load_camf()' function (dcraw_foveon.c) could
lead to Denial of service (bsc#1039210)

- CVE-2017-6890: boundary error within the
'foveon_load_camf()' function (dcraw_foveon.c)
(bsc#1039209)

Note that Tenable Network Security has extracted the preceding
description block directly from the SUSE security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

See also :

https://bugzilla.suse.com/1039209
https://bugzilla.suse.com/1039210
https://bugzilla.suse.com/1039379
https://bugzilla.suse.com/1039380
https://bugzilla.suse.com/930683
https://bugzilla.suse.com/957517
https://www.suse.com/security/cve/CVE-2015-3885.html
https://www.suse.com/security/cve/CVE-2015-8367.html
https://www.suse.com/security/cve/CVE-2017-6886.html
https://www.suse.com/security/cve/CVE-2017-6887.html
https://www.suse.com/security/cve/CVE-2017-6889.html
https://www.suse.com/security/cve/CVE-2017-6890.html
https://www.suse.com/security/cve/CVE-2017-6899.html
http://www.nessus.org/u?f6954c2b

Solution :

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Workstation Extension 12-SP3:zypper in -t patch
SUSE-SLE-WE-12-SP3-2017-1416=1

SUSE Linux Enterprise Workstation Extension 12-SP2:zypper in -t patch
SUSE-SLE-WE-12-SP2-2017-1416=1

SUSE Linux Enterprise Software Development Kit 12-SP3:zypper in -t
patch SUSE-SLE-SDK-12-SP3-2017-1416=1

SUSE Linux Enterprise Software Development Kit 12-SP2:zypper in -t
patch SUSE-SLE-SDK-12-SP2-2017-1416=1

SUSE Linux Enterprise Desktop 12-SP3:zypper in -t patch
SUSE-SLE-DESKTOP-12-SP3-2017-1416=1

SUSE Linux Enterprise Desktop 12-SP2:zypper in -t patch
SUSE-SLE-DESKTOP-12-SP2-2017-1416=1

To bring your system up-to-date, use 'zypper patch'.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:ND)
Public Exploit Available : false

Family: SuSE Local Security Checks

Nessus Plugin ID: 102855 ()

Bugtraq ID: 74590

CVE ID: CVE-2015-3885
CVE-2015-8367
CVE-2017-6886
CVE-2017-6887
CVE-2017-6889
CVE-2017-6890
CVE-2017-6899

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now