GLSA-201708-08 : bzip2: Denial of Service

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201708-08
(bzip2: Denial of Service)

A use-after-free flaw was found in bzip2recover, leading to a null
pointer dereference, or a write to a closed file descriptor. Please
review the CVE identifier referenced below for details.

Impact :

A remote attacker could entice a user to process a specially crafted
bzip2 archive using bzip2recover, possibly resulting in a Denial of
Service condition.

Workaround :

There is no known workaround at this time.

See also :

https://security.gentoo.org/glsa/201708-08

Solution :

All bzip2 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-arch/bzip2-1.0.6-r8'

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 102620 ()

Bugtraq ID:

CVE ID: CVE-2016-3189

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now