Apache Tomcat 8.5.x < 8.5.16 Multiple Vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat server is affected by multiple

Description :

The version of Apache Tomcat installed on the remote host is 8.5.x
prior to 8.5.16. It is, therefore, affected by multiple
vulnerabilities :

- A flaw exists in the CORS filter because the HTTP Vary header was
not properly added. This allows a remote attacker to conduct
client-side and server-side cache poisoning attacks.

- A flaw exists in the HTTP/2 implementation that bypasses a number
of security checks that prevented directory traversal attacks. A
remote attacker can exploit this to bypass security constraints.

Note that Nessus has not attempted to exploit this issue but has
instead relied only on the application's self-reported version number.

See also :


Solution :

Upgrade to Apache Tomcat version 8.5.16 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 102589 ()

Bugtraq ID: 100256

CVE ID: CVE-2017-7674

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now