openSUSE Security Update : libplist (openSUSE-2017-953)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for libplist fixes the following issues :

Security issues fixed :

- CVE-2017-6439: Heap-based buffer overflow in the
parse_string_node function. (bsc#1029638)

- CVE-2017-6438: Heap-based buffer overflow in the
parse_unicode_node function. (bsc#1029706)

- CVE-2017-6437: The base64encode function in base64.c
allows local users to cause denial of service
(out-of-bounds read) via a crafted plist file.
(bsc#1029707)

- CVE-2017-6436: Integer overflow in parse_string_node.
(bsc#1029751)

- CVE-2017-6435: Crafted plist file could lead to
Heap-buffer overflow. (bsc#1029639)

This update was imported from the SUSE:SLE-12-SP2:Update update
project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1029638
https://bugzilla.opensuse.org/show_bug.cgi?id=1029639
https://bugzilla.opensuse.org/show_bug.cgi?id=1029706
https://bugzilla.opensuse.org/show_bug.cgi?id=1029707
https://bugzilla.opensuse.org/show_bug.cgi?id=1029751

Solution :

Update the affected libplist packages.

Risk factor :

Medium / CVSS Base Score : 4.4
(CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 102568 ()

Bugtraq ID:

CVE ID: CVE-2017-6435
CVE-2017-6436
CVE-2017-6437
CVE-2017-6438
CVE-2017-6439

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now