openSUSE Security Update : openldap2 (openSUSE-2017-936)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for openldap2 fixes the following issues :

- Let OpenLDAP read system wide certificate directory by
default and avoid hiding the error if user specified CA
location cannot be read (boo#1009470).

- Fix CVE-2017-9287: openldap2: Double free vulnerability
with patch (boo#1041764)

- Fix an uninitialized variable that causes startup
failure (boo#1037396)

- Fix a regression in handling of non-blocking connection
with (boo#1031702)

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1009470
https://bugzilla.opensuse.org/show_bug.cgi?id=1031702
https://bugzilla.opensuse.org/show_bug.cgi?id=1037396
https://bugzilla.opensuse.org/show_bug.cgi?id=1041764

Solution :

Update the affected openldap2 packages.

Risk factor :

Medium / CVSS Base Score : 4.0
(CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 102555 ()

Bugtraq ID:

CVE ID: CVE-2017-9287

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now