Adobe Flash Player for Mac <= 26.0.0.137 Multiple Vulnerabilities (APSB17-23)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote macOS or Mac OS X host has a browser plugin installed that
is affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote macOS or Mac
OS X host is equal or prior to version 26.0.0.137. It is, therefore,
affected by multiple vulnerabilities :

- An information disclosure vulnerability exists due to an
unspecified flaw. An unauthenticated, remote attacker
can exploit this, by convincing a user to visit a
website containing specially crafted Flash content, to
disclose sensitive information. (CVE-2017-3085)

- A remote code execution vulnerability exists due to
improper validation of user-supplied input. An
unauthenticated, remote attacker can exploit this, by
convincing a user to visit a website containing
specially crafted Flash content, to execute arbitrary
code. (CVE-2017-3106)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb17-23.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 26.0.0.151 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 102263 ()

Bugtraq ID: 100191

CVE ID: CVE-2017-3085
CVE-2017-3106

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now