FreeBSD : gsoap -- remote code execution via via overflow (8745c67e-7dd1-4165-96e2-fcf9da2dc5b5)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

Senrio reports :

Genivia gSOAP is prone to a stack-based buffer-overflow vulnerability
because it fails to properly bounds check user-supplied data before
copying it into an insufficiently sized buffer.

A remote attacker may exploit this issue to execute arbitrary code in
the context of the affected device. Failed attempts will likely cause
a denial-of-service condition.

See also :

http://www.securityfocus.com/bid/99868/discuss
http://www.nessus.org/u?3e535581
http://blog.senr.io/devilsivy.html
http://www.nessus.org/u?a5545454
http://www.nessus.org/u?91af07d9
http://www.nessus.org/u?9d4bf347

Solution :

Update the affected package.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 101967 ()

Bugtraq ID:

CVE ID: CVE-2017-9765

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now