Wireshark 2.0.x < 2.0.14 / 2.2.x < 2.2.8 Multiple DoS (macOS)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

An application installed on the remote macOS or Mac OS X host is
affected by multiple denial of service vulnerabilities.

Description :

The version of Wireshark installed on the remote macOS or Mac OS X
host is 2.0.x prior to 2.0.14 or 2.2.x prior to 2.2.8. It is,
therefore, affected by multiple denial of service vulnerabilities :

- A denial of service vulnerability exists in the DAAP
dissector, specifically in the dissect_daap_one_tag()
function within file epan/dissectors/packet-daap.c. An
unauthenticated, remote attacker can exploit this to
exhaust stack resources through uncontrolled recursion.
(CVE-2017-9617)

- An infinite loop condition exists in the DOCSIS
dissector, specifically in the dissect_docsis() function
within file plugins/docsis/packet-docsis.c. An
unauthenticated, remote attacker can exploit this, via a
specially crafted packet or packet trace, to consume
available CPU resources, resulting in a denial of
service condition. (CVE-2017-11406)

- A memory allocation issue exists in the MQ dissector,
specifically in the reassemble_mq() function within file
epan/dissectors/packet-mq.c, due to improper validation
of fragment lengths before attempting reassembly. An
unauthenticated, remote attacker can exploit this, via a
specially crafted packet or packet trace, to cause a
denial of service condition. (CVE-2017-11407)

- A flaw exists in the AMQP dissector, specifically in
the get_amqp_1_0_value_formatter() function within file
epan/dissectors/packet-amqp.c, when decoding lists.
An unauthenticated, remote attacker can exploit this,
via a specially crafted packet or packet trace, to cause
a stack overflow, resulting in a denial of service
condition. (CVE-2017-11408)

- A large loop condition exists in the GPRS LLC dissector,
specifically in the llc_gprs_dissect_xid() function
within file epan/dissectors/packet-gprs-llc.c, when
handling specially crafted packet or trace files. An
unauthenticated, remote attacker can exploit this to
cause a denial of service condition. Note that this
issue only applies to version 2.0.x. (CVE-2017-11409)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

https://www.wireshark.org/docs/relnotes/wireshark-2.0.14.html
https://www.wireshark.org/docs/relnotes/wireshark-2.2.8.html
https://www.wireshark.org/security/wnpa-sec-2017-34.html
https://www.wireshark.org/security/wnpa-sec-2017-35.html
https://www.wireshark.org/security/wnpa-sec-2017-36.html
https://www.wireshark.org/security/wnpa-sec-2017-37.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=13799

Solution :

Upgrade to Wireshark version 2.0.14 / 2.2.8 or later.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 6.4
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 101897 ()

Bugtraq ID: 99087

CVE ID: CVE-2017-9617
CVE-2017-11406
CVE-2017-11407
CVE-2017-11408
CVE-2017-11409

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now