IBM WebSphere MQ 9.0.1 < 9.0.3 Multiple Vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

A message queuing service installed on the remote host is affected by
multiple vulnerabilities.

Description :

According to its self-reported version, the IBM WebSphere MQ server
installed on the remote Windows host is 9.0.1 or 9.0.2 prior to 9.0.3.
It is, therefore, affected by multiple vulnerabilities :

- An information disclosure vulnerability exists due to
the insecure transmission of credentials in cleartext. A
man-in-the-middle attacker can exploit this to disclose
password information. Note that the software is only
affected when PASSWORDPROTECTION=ALWAYS is set in
mqclient.ini. (CVE-2017-1337)

- An information disclosure vulnerability exists in
WebSphere Application server traces when establishing
CLIENT transport mode connections. A local attacker can
exploit this to disclose sensitive information including
passwords. (CVE-2017-1284)

- A denial of service vulnerability exists due to improper
handling of invalid messages. An authenticated, remote
attacker can exploit this to cause an SDR or CLUSSDR
channel to stop processing messages.

See also :

https://www-01.ibm.com/support/docview.wss?uid=swg22003851
https://www-01.ibm.com/support/docview.wss?uid=swg22003853
https://www-01.ibm.com/support/docview.wss?uid=swg22003856

Solution :

Upgrade to WebSphere MQ version 9.0.3 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 101838 ()

Bugtraq ID: 99493
99494
99538

CVE ID: CVE-2017-1337
CVE-2017-1284
CVE-2017-1285

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now