Apache 2.2.x < 2.2.34 Multiple Vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of Apache running on the remote
host is 2.2.x prior to 2.2.34. It is, therefore, affected by the
following vulnerabilities :

- An authentication bypass vulnerability exists in httpd
due to third-party modules using the
ap_get_basic_auth_pw() function outside of the
authentication phase. An unauthenticated, remote
attacker can exploit this to bypass authentication
requirements. (CVE-2017-3167)

- A denial of service vulnerability exists in httpd due to
a NULL pointer dereference flaw that is triggered when a
third-party module calls the mod_ssl
ap_hook_process_connection() function during an HTTP
request to an HTTPS port. An unauthenticated, remote
attacker can exploit this to cause a denial of service
condition. (CVE-2017-3169)

- A denial of service vulnerability exists in httpd due to
an out-of-bounds read error in the ap_find_token()
function that is triggered when handling a specially
crafted request header sequence. An unauthenticated,
remote attacker can exploit this to crash the
service or force ap_find_token() to return an incorrect
value. (CVE-2017-7668)

- A denial of service vulnerability exists in httpd due to
an out-of-bounds read error in the mod_mime that is
triggered when handling a specially crafted Content-Type
response header. An unauthenticated, remote attacker can
exploit this to disclose sensitive information or cause
a denial of service condition. (CVE-2017-7679)

- A denial of service vulnerability exists in httpd due to
a failure to initialize or reset the value placeholder
in [Proxy-]Authorization headers of type 'Digest' before
or between successive key=value assignments by
mod_auth_digest. An unauthenticated, remote attacker can
exploit this, by providing an initial key with no '='
assignment, to disclose sensitive information or cause a
denial of service condition. (CVE-2017-9788)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

https://archive.apache.org/dist/httpd/CHANGES_2.2.34
https://httpd.apache.org/security/vulnerabilities_22.html

Solution :

Upgrade to Apache version 2.2.34 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 101787 ()

Bugtraq ID: 99134
99135
99137
99170
99569

CVE ID: CVE-2017-3167
CVE-2017-3169
CVE-2017-7668
CVE-2017-7679
CVE-2017-9788

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now