IBM Integration Bus 8.x < 8.0.0.9 / 9.x < 9.0.0.8 / 10.x < 10.0.0.8 Multiple Vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

An enterprise service bus application installed on the remote host is
affected by multiple vulnerabilities.

Description :

The version of IBM Integration Bus (formerly known as IBM WebSphere
Message Broker) installed on the remote host is 8.x prior to 8.0.0.9,
9.x prior to 9.0.0.8, or 10.x prior to 10.0.0.8. It is, therefore,
affected by multiple vulnerabilities :

- A denial of service vulnerability exists due to the use
of an unquoted search path that allows a local attacker
with specialized access to prevent the message broker
from starting. (CVE-2017-1144)

- An information disclosure vulnerability exists in the
service trace component due to logging passwords in
plaintext. A local attacker can exploit this to disclose
web user passwords. (CVE-2017-1207)

See also :

https://www-01.ibm.com/support/docview.wss?uid=swg22005382
https://www-01.ibm.com/support/docview.wss?uid=swg22005383

Solution :

Upgrade to IBM Integration Bus version 8.0.0.9 / 9.0.0.8 / 10.0.0.8 or
later.

Risk factor :

Medium / CVSS Base Score : 4.9
(CVSS2#AV:L/AC:L/Au:N/C:C/I:N/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 101521 ()

Bugtraq ID: 99365
99368

CVE ID: CVE-2017-1144
CVE-2017-1207

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now