Adobe Flash Player <= 26.0.0.131 Multiple Vulnerabilities (APSB17-21)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin installed that is
affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote Windows host
is equal or prior to version 26.0.0.131. It is, therefore, affected by
multiple vulnerabilities :

- An information disclosure vulnerability exists due to an
unspecified flaw. An unauthenticated, remote attacker
can exploit this, by convincing a user to visit a
website containing specially crafted Flash content, to
disclose sensitive information. (CVE-2017-3080)

- A remote code execution vulnerability exists due to
improper validation of user-supplied input. An
unauthenticated, remote attacker can exploit this, by
convincing a user to visit a website containing
specially crafted Flash content, to execute arbitrary
code. (CVE-2017-3099)

- An information disclosure vulnerability exists that
allows an unauthenticated, remote attacker to corrupt
memory and disclose memory addresses. (CVE-2017-3100)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb17-21.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 26.0.0.137 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 101362 ()

Bugtraq ID: 99519
99520
99523

CVE ID: CVE-2017-3080
CVE-2017-3099
CVE-2017-3100

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now