OracleVM 3.2 : Unbreakable / etc (OVMSA-2017-0121)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote OracleVM host is missing one or more security updates.

Description :

The remote OracleVM system is missing necessary patches to address
critical security updates :

- nfsd: check for oversized NFSv2/v3 arguments (J. Bruce
Fields) [Orabug: 26366024] (CVE-2017-7645)

- dm mpath: allow ioctls to trigger pg init (Mikulas
Patocka) [Orabug: 25645229]

- xen/manage: Always freeze/thaw processes when
suspend/resuming (Ross Lagerwall) [Orabug: 25795530]

- lpfc cannot establish connection with targets that send
PRLI under P2P mode (Joe Jin) [Orabug: 25955028]

- nvme: Handle PM1725 HIL reset (Martin K. Petersen)
[Orabug: 26277602]

- dccp/tcp: do not inherit mc_list from parent (Eric
Dumazet) [Orabug: 26108573] (CVE-2017-8890)

- cifs: adjust sequence number downward after signing
NT_CANCEL request (Albert Barbe)

- nfsd: stricter decoding of write-like NFSv2/v3 ops (J.
Bruce Fields) [Orabug: 25986995] (CVE-2017-7895)

See also :

https://oss.oracle.com/pipermail/oraclevm-errata/2017-July/000749.html

Solution :

Update the affected kernel-uek / kernel-uek-firmware packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: OracleVM Local Security Checks

Nessus Plugin ID: 101200 ()

Bugtraq ID:

CVE ID: CVE-2017-7645
CVE-2017-7895
CVE-2017-8890

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now