Poppler < 0.56.0 Multiple Vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

A package installed on the remote host is affected by multiple
vulnerabilities.

Description :

The version of Poppler installed on the remote host is prior to
0.56.0. It is, therefore, affected by multiple vulnerabilities :

- A stack-based overflow condition exists in the
getColor() function in GfxState.cc due to improper
validation of user-supplied input. An unauthenticated,
remote attacker can exploit this, by convincing a user
to open a specially crafted PDF document, to crash the
process, resulting in a denial of service condition.
(CVE-2017-9775)

- An integer overflow condition exists in the combine()
function in JBIG2Stream.cc due to improper validation of
user-supplied input. An unauthenticated, remote attacker
can exploit this, by convincing a user to open a
specially crafted PDF document, to cause a denial of
service condition or the execution of arbitrary code.
(CVE-2017-9775)

See also :

https://bugs.freedesktop.org/show_bug.cgi?id=101540
https://bugs.freedesktop.org/show_bug.cgi?id=101541

Solution :

Upgrade to Poppler version 0.56.0 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 101167 ()

Bugtraq ID: 99240
99241

CVE ID: CVE-2017-9775
CVE-2017-9776

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now